Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 2 months ago. Feb 03, 2017 - 19:02 EDT
Monitoring
Monitoring at this time
Posted about 2 months ago. Feb 03, 2017 - 17:17 EDT
Update
We are currently working to restore services to #Smite #PC
Posted about 2 months ago. Feb 03, 2017 - 15:38 EDT
Identified
We will be performing an emergency restart of #Smite on #PC.
Posted about 2 months ago. Feb 03, 2017 - 13:17 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 2 months ago. Feb 03, 2017 - 13:13 EDT
This incident affected: Smite PC - North America / Europe.