Disconnections
Incident Report for Hi-Rez Studios, Inc
Resolved
Disconnection issues have been resolved; all games / platforms operational.
Posted 10 months ago. Jun 16, 2016 - 00:04 EDT
Investigating
We are currently working to resolve the issues effecting connectivity to our game services.
Sorry for the inconvenience.
Posted 10 months ago. Jun 15, 2016 - 20:53 EDT