Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issues with #SMITE #PS4 have been resolved.
Posted May 26, 2017 - 03:47 EDT
Monitoring
We have identified and mitigated the issue with #SMITE #PS4 and are currently monitoring it
Posted May 26, 2017 - 03:34 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted May 26, 2017 - 03:18 EDT
This incident affected: SMITE (SMITE PS4).