Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved. #Paladins #PC
Posted 3 months ago. Mar 04, 2017 - 18:38 EST
Update
At this moment logins have resume for #Paladins #PC.
We are continuing to monitor the environment for possible issues.
Thank you for your continued patience.
Posted 3 months ago. Mar 04, 2017 - 17:14 EST
Update
We are continuing our investigation into the issues effecting #Paladins #PC.
We are sorry for the inconvenience, please check back for updates periodically.
Posted 3 months ago. Mar 04, 2017 - 15:52 EST
Monitoring
We are continuing to work the issues effecting match making on #Paladins #PC.
Posted 3 months ago. Mar 04, 2017 - 14:01 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 3 months ago. Mar 04, 2017 - 13:02 EST
This incident affected: Paladins PC.