Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 8 months ago. Feb 11, 2017 - 12:09 EST
Monitoring
At this time logins have resumed and we are continuing to monitor #Smite
Posted 8 months ago. Feb 11, 2017 - 11:52 EST
Update
We will be performing an emergency restart of #Smite on #PC
Posted 8 months ago. Feb 11, 2017 - 11:33 EST
Identified
We are currently investigating potential issues with match creation on #Smite #PC
Posted 8 months ago. Feb 11, 2017 - 11:23 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 8 months ago. Feb 11, 2017 - 11:22 EST
This incident affected: Smite PC - North America / Europe.