Paladins & Smite Web Store Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This #Paladins & #Smite web store issue has been resolved.
Posted 30 days ago. Aug 23, 2019 - 18:58 EDT
Investigating
We are currently experiencing an issue with the Web Store for #Paladins & #Smite
Posted 30 days ago. Aug 23, 2019 - 17:14 EDT
This incident affected: Paladins (Paladins PC), Smite (Smite PC), and Realm Royale (Realm Royale PC).