Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Issues impacting #Paladins PC have been addressed and are resolved.
Posted May 28, 2017 - 14:26 EDT
Monitoring
#Paladins PC experienced a brief issue impacting logins and match-making; we have mitigated the issue and are continuing to monitor
Posted May 28, 2017 - 13:44 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted May 28, 2017 - 13:29 EDT
This incident affected: Paladins (Paladins PC).