Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved#smite
Posted 10 months ago. Dec 28, 2016 - 22:49 EST
Update
Investigating: We are currently investigating this Smite PC issue#smite
Posted 10 months ago. Dec 28, 2016 - 22:35 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 10 months ago. Dec 28, 2016 - 22:29 EST
This incident affected: Smite PC - North America / Europe.