Disconnections
Incident Report for Hi-Rez Studios, Inc
Resolved
This issue has been resolved.
Posted 10 months ago. Jun 09, 2016 - 20:30 EDT
Identified
We are currently investigating the issues with connecting to our game services.
Sorry for the inconvenience.
Posted 10 months ago. Jun 09, 2016 - 19:10 EDT