Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The logins issues impacting #Paladins have subsided.
Posted 9 months ago. Sep 27, 2016 - 20:17 EDT
Identified
We are aware of the login Issues effecting #Paladins.
We apologize for the inconvenience.
Posted 9 months ago. Sep 27, 2016 - 17:07 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 9 months ago. Sep 27, 2016 - 17:03 EDT