Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#SMITE XBOX back to normal; closing event; GAME ON!
Posted 4 months ago. Nov 25, 2016 - 18:29 EDT
Monitoring
#SMITE XBOX is back up and accepting logins; all initial testing looks positive; continuing to monitor...
Posted 4 months ago. Nov 25, 2016 - 18:03 EDT
Identified
#SMITE XBOX emergency restart; service back to normal shortly; apologies on the inconvenience
Posted 4 months ago. Nov 25, 2016 - 17:39 EDT
Update
Continued issues with #SMITE XBOX; working to resolve...should have update shortly.
Posted 4 months ago. Nov 25, 2016 - 17:18 EDT
Update
#SMITE XBox is experiencing issues. Operations staff working to resolve. Services should return to normal shortly. Apologies for the inconvenience.
Posted 4 months ago. Nov 25, 2016 - 16:52 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 4 months ago. Nov 25, 2016 - 16:21 EDT