Smite PS4 Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This #Smite #PS4 issue has been resolved.
Posted 14 days ago. Aug 07, 2018 - 15:34 EDT
Monitoring
#Smite #PS4 is back up. We are monitoring the results.
Posted 14 days ago. Aug 07, 2018 - 15:16 EDT
Identified
We are performing an emergency restart for #Smite #PS4. Game will be back up soon.
Posted 14 days ago. Aug 07, 2018 - 15:04 EDT
This incident affected: Smite (Smite PS4).