Smite Xbox Match Manager Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This #Smite #Xbox Match Manager issue has been resolved.
Posted 12 days ago. Jul 10, 2018 - 15:03 EDT
Monitoring
#Smite #Xbox logins have resumed. We are continuing to monitor.
Posted 12 days ago. Jul 10, 2018 - 14:19 EDT
Identified
We have identified an issue with #Smite #Xbox Match Manager. Logins have temporarily been limited to address this issue.
Posted 12 days ago. Jul 10, 2018 - 14:12 EDT
This incident affected: Smite (Smite Xbox).