Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
the purchasing issue with #SMITE PC has been corrected
Posted 11 months ago. Jun 23, 2016 - 10:11 EDT
Update
Users may have issues with web or in game purchases for Smite PC, we are working to fix the issue#smite
Posted 11 months ago. Jun 23, 2016 - 07:18 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 11 months ago. Jun 23, 2016 - 06:26 EDT