Hirez Games possible issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This incident has been resolved..#SMITE #Tribes #Paladins
Posted about 1 year ago. Jun 23, 2016 - 03:18 EDT
Update
We are experiencing Data Center problems, we are still working to resolve the issue, All Games Are affected.#SMITE #Tribes #Paladins
Posted about 1 year ago. Jun 23, 2016 - 03:13 EDT
Update
We are experiencing Data Center problems, we are working to resolve the issue, All Games Are affected.#SMITE #Tribes #Paladins
Posted about 1 year ago. Jun 23, 2016 - 02:37 EDT
Investigating
Automated services have detected a possible problem our Atlanta servers and may affect all games. #SMITE #Tribes #Paladins. We are investigating.
Posted about 1 year ago. Jun 23, 2016 - 02:18 EDT