Smite PC experiencing login issues
Incident Report for Hi-Rez Studios, Inc
Resolved
Logins have been re-enabled for #Smite PC; the issue has been resolved; apologies for the inconvenience.
Posted 11 months ago. Jun 08, 2016 - 17:01 EDT
Monitoring
Logins remain limited on #Smite PC as we continue to monitor performance; we expect to be re-enabling logins shortly; thank you for your patience
Posted 11 months ago. Jun 08, 2016 - 16:46 EDT
Update
Logins are momentarily limited on #Smite PC; we are monitoring the Login issue and are working to resolve
Posted 11 months ago. Jun 08, 2016 - 16:36 EDT
Identified
#Smite PC is experiencing an issue that is impacting player logins; we have identified the issue and are working to resolve
Posted 11 months ago. Jun 08, 2016 - 16:32 EDT