Paladins Cross-Play Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
Restart has completed for #Paladins #Crossplay, we will continue to monitor.
Posted about 1 month ago. Jul 17, 2019 - 13:56 EDT
Identified
#Paladins #Crossplay is performing an emergency restart.

Game will be back up soon, and we will update accordingly.
Posted about 1 month ago. Jul 17, 2019 - 13:36 EDT
This incident affected: Paladins (Paladins PC, Paladins Xbox, Paladins Switch).