Smite PC Emergency Hot-Fix
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted over 1 year ago. Sep 13, 2016 - 13:23 EDT
Investigating
We will be performing an emergeny hot-fix on #Smite for PC.
Limited access will begin at 12:20 PM EDT.
Posted over 1 year ago. Sep 13, 2016 - 12:27 EDT