Paladins Crossplay Server Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted May 26, 2019 - 15:29 EDT
Monitoring
The restart has been completed for #Paladins #PC #Xbox and #Switch. We will continue to monitor.
Posted May 26, 2019 - 14:59 EDT
Update
The restart has been completed for #Paladins #PC #Xbox and #Switch. We will continue to monitor.
Posted May 26, 2019 - 14:42 EDT
Update
We are performing an emergency restart on #Paladins #PC #Xbox and #Switch.
Posted May 26, 2019 - 14:20 EDT
Investigating
We are experiencing issues with #Paladins #PC #Xbox and #Switch.
Posted May 26, 2019 - 14:03 EDT
This incident affected: Paladins (Paladins PC, Paladins Xbox, Paladins Switch).