Smite PC Server Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 10 days ago. Nov 07, 2018 - 19:48 EST
Investigating
We are currently investigating this issue.
Posted 10 days ago. Nov 07, 2018 - 19:32 EST
This incident affected: Smite (Smite PC).