Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This issue with #Smite #PC has been resolved.
Posted 10 months ago. Jan 31, 2018 - 21:27 EST
Monitoring
We are monitoring a possible issue with #Smite #PC.
Posted 10 months ago. Jan 31, 2018 - 21:05 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 10 months ago. Jan 31, 2018 - 20:49 EST
This incident affected: Smite (Smite PC).