Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#SMITE #XBOX has returned to normal; this is resolved.
Posted about 2 months ago. Feb 07, 2017 - 21:30 EDT
Monitoring
emergency restart of #SMITE #XBOX is complete; logins are enabled; continuing to monitor
Posted about 2 months ago. Feb 07, 2017 - 21:19 EDT
Update
We are still working on returning #SMITE #XBOX to service; apologies for the delay.
Posted about 2 months ago. Feb 07, 2017 - 21:10 EDT
Update
We will be performing an emergency restart of #SMITE #XBOX; apologies for the inconvenience.
Posted about 2 months ago. Feb 07, 2017 - 20:47 EDT
Identified
We have identified an issue with #SMITE #XBOX; logins are temporarily disabled; game should be back shortly.
Posted about 2 months ago. Feb 07, 2017 - 20:30 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted about 2 months ago. Feb 07, 2017 - 20:21 EDT
This incident affected: Smite Xbox - North America / Europe.