Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This issue with #Smite #Xbox has been resolved.
Posted 8 months ago. Jan 31, 2018 - 22:03 EST
Monitoring
#Smite #Xbox emergency restart has been completed. We are monitoring the results.
Posted 8 months ago. Jan 31, 2018 - 21:16 EST
Identified
We are performing an emergency restart for #Smite #Xbox. The game will be back up shortly
Posted 8 months ago. Jan 31, 2018 - 20:31 EST
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 8 months ago. Jan 31, 2018 - 20:31 EST
This incident affected: Smite (Smite Xbox).