Tribes unscheduled restart 5:45pm EST
Incident Report for Hi-Rez Studios, Inc
Resolved
Restart complete. The NA-East pings have returned to normal.
Posted almost 2 years ago. Dec 10, 2015 - 17:57 EST
Investigating
We will be restarting Tribes at 5:45pm to resolve some high ping issues #tribes
Posted almost 2 years ago. Dec 10, 2015 - 17:37 EST