Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite XBOX incident has been resolved#smite
Posted over 1 year ago. Mar 02, 2016 - 19:48 EST
Update
We are pausing logins temporarily on smite XBox to sort out some issues with matches being launched.
Sorry for the inconvenience.
#smite
Posted over 1 year ago. Mar 02, 2016 - 18:51 EST
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted over 1 year ago. Mar 02, 2016 - 18:39 EST