Smite PC Steam Users Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
#Smite #PC has now been deployed to Steam
Posted 19 days ago. Jun 06, 2017 - 10:51 EDT
Identified
Currently we are unable to release the patch on Steam. When it is fixed we will release the patch. #SmitePC
Posted 19 days ago. Jun 06, 2017 - 08:35 EDT
This incident affected: Smite PC - North America / Europe.