Hand of the Gods Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Nov 21, 2019 - 13:16 EST
Investigating
We are investigating the Login Issues for #HandoftheGods #PC
Posted Nov 21, 2019 - 13:09 EST
This incident affected: Hand of the Gods (Hand of the Gods PC).