Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
We believe the issues involving #Smite #PS4 have been resolved.
We are continuing to monitor the situation closely.
Posted May 20, 2017 - 15:13 EDT
Identified
We will be pausing logins to investigate possible issues with #Smite on #PS4.
Posted May 20, 2017 - 14:33 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted May 20, 2017 - 14:26 EDT
This incident affected: SMITE (SMITE PS4).