Brazilian Server Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Jan 09, 2020 - 19:16 EST
Investigating
We are investigating an issue that is affecting the Brazilian region across all games. Players playing in this region may experience high ping during this time.
Posted Jan 09, 2020 - 18:48 EST
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch), Paladins (Paladins PC, Paladins PS4, Paladins Xbox, Paladins Switch), and Realm Royale Reforged (Realm Royale PC, Realm Royale PS4, Realm Royale Xbox, Realm Royale Switch).