Paladins PC login and performance issues
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue has been resolved and we will continue to monitor #Paladins #PC
Posted Aug 19, 2017 - 16:47 EDT
Investigating
We are aware of the issues in performance with logins and getting matches, we are working on a fix for these issues. #PALADINSPC
Posted Aug 19, 2017 - 12:49 EDT
This incident affected: Paladins (Paladins PC).