Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted almost 2 years ago. Feb 13, 2016 - 00:24 EST
Monitoring
We are currently working to resolve some server stability issues.
#SMITE
Posted almost 2 years ago. Feb 13, 2016 - 00:07 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted almost 2 years ago. Feb 12, 2016 - 23:59 EST