Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 year ago. Feb 16, 2016 - 17:33 EST
Identified
Some people are having issues Login into Smite XBOX, XBOX Live is currently having issues with people Signing in; creating, managing, or recovering an account; search
#smite
Posted about 1 year ago. Feb 16, 2016 - 16:55 EST
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted about 1 year ago. Feb 16, 2016 - 16:51 EST