Rogue Company Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Aug 05, 2020 - 23:30 EDT
Monitoring
Logins have returned. We will continue to monitor the results.
Posted Aug 05, 2020 - 22:10 EDT
Investigating
We are currently investigating an issue that is affecting logins.
Posted Aug 05, 2020 - 21:41 EDT
This incident affected: Rogue Company (Rogue Company PC, Rogue Company PS4, Rogue Company Xbox, Rogue Company Switch, Rogue Company Epic).