Paladins PC Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with #Paladins #PC has been resolved.
Posted Jul 20, 2017 - 14:16 EDT
Monitoring
The emergency restart of #Paladins #PC has been completed. We are monitoring the results.
Posted Jul 20, 2017 - 13:53 EDT
Identified
We have identified an issue with #Paladins #PC and will be performing an emergency restart. The game will be up shortly.
Posted Jul 20, 2017 - 13:38 EDT
This incident affected: Paladins (Paladins PC).