Hi-Rez Connectivity Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
We have recovered from this issue and affected game environments are back up.
Posted 11 months ago. Jul 12, 2017 - 09:36 EDT
Monitoring
We are recovering from the netowork issue and will continue to monitor.
Posted 11 months ago. Jul 12, 2017 - 09:24 EDT
Identified
We are currently experiencing an issue that effects all Hi-Rez Products. We have identified the issue and working on restoring services.
Posted 11 months ago. Jul 12, 2017 - 08:54 EDT
This incident affected: Paladins (Paladins PC, Paladins PS4, Paladins Xbox), Smite (Smite PC, Smite PS4, Smite Xbox), Hand of the Gods (Hand of the Gods PC), Tribes Ascend (Tribes Ascend), and Hi-Rez Studios (Hi-Rez Public APIs).