Smite XBox Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 07, 2018 - 23:29 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. Aug 07, 2018 - 23:16 EDT
Identified
We will be performing an emergency restart of Smite on XBox momentarily. We will be back up shortly.
Posted 4 months ago. Aug 07, 2018 - 23:06 EDT
This incident affected: Smite (Smite Xbox).