Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This issue is now resolved .
Posted about 2 months ago. Feb 03, 2017 - 14:10 EDT
Monitoring
The issues has been isolated. We are currently monitoring at this time
Posted about 2 months ago. Feb 03, 2017 - 13:54 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted about 2 months ago. Feb 03, 2017 - 13:23 EDT