Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This smite xbox incident has been resolved#smite
Posted 10 months ago. Sep 06, 2016 - 22:52 EDT
Identified
Microsoft has been rolling out firmware updates this evening for XBOX One#smite
Posted 10 months ago. Sep 06, 2016 - 20:48 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 10 months ago. Sep 06, 2016 - 20:15 EDT