Smite PC, Xbox, Switch. and PS4 emergency maintenance
Incident Report for Hi-Rez Studios, Inc
Resolved
The emergency maintenance has been completed.
Posted 5 months ago. Apr 05, 2019 - 08:49 EDT
Investigating
We are performing an emergency maintenance on Smite
Posted 5 months ago. Apr 05, 2019 - 07:54 EDT
This incident affected: Smite (Smite PC, Smite PS4, Smite Xbox, Smite Switch).