Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted May 21, 2017 - 12:27 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 21, 2017 - 12:17 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted May 21, 2017 - 12:13 EDT
This incident affected: Paladins (Paladins PC).