Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#SMITE PC Steam issues have subsided...
Posted 11 months ago. Apr 26, 2016 - 09:37 EDT
Identified
#SMITE PC users that use the Steam client are having issues due to issues at Steam: https://steamstat.us/
Posted 11 months ago. Apr 26, 2016 - 09:28 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 11 months ago. Apr 26, 2016 - 09:23 EDT