Smite PC emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted almost 2 years ago. Mar 03, 2016 - 08:46 EST
Investigating
We will be taking down Smite PC for an emergency restart.
Sorry for the inconvenience.
#SMITE
Posted almost 2 years ago. Mar 03, 2016 - 08:15 EST