Smite Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
The emergency restart of #Smite is complete. Logins and matchmaking have resolved. We will continue to monitor the results.
Posted Jan 31, 2021 - 00:03 EST
Investigating
We are performing an emergency restart of #Smite to help address issues with matchmaking. The game will be back shortly.
Posted Jan 30, 2021 - 23:37 EST
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch, SMITE Epic).