Paladins Crossplay Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Apr 02, 2020 - 06:36 EDT
Identified
Game is back up and we are currently monitoring.
Posted Apr 02, 2020 - 06:25 EDT
Investigating
We will be performing an emergency restart for Paladins Crossplay at 6AM EDT / 10:00 UTC. We apologize for the inconvenience.
Posted Apr 02, 2020 - 05:43 EDT
This incident affected: Paladins (Paladins PC, Paladins PS4, Paladins Xbox, Paladins Switch).