We will be performing a restart of Paladins on PS4
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 9 months ago. Feb 24, 2017 - 12:52 EST
Investigating
We are currently investigating this issue.
Posted 9 months ago. Feb 24, 2017 - 12:10 EST
This incident affected: Paladins PS4.