Realm Royale Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 6 months ago. Jun 11, 2018 - 13:54 EDT
Identified
We have found the issue with Match Manager and have taken actions to correct the issue and will continue to monitor closely.
Posted 6 months ago. Jun 11, 2018 - 13:31 EDT
Investigating
We are currently looking into issues with our Match Manager.
Posted 6 months ago. Jun 11, 2018 - 13:21 EDT
This incident affected: Realm Royale (Realm Royale PC).