Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue impacting #Smite PC has been resolved
Posted 5 months ago. Feb 02, 2017 - 20:52 EST
Identified
We will be performing an emergency restart of #Smite #PC.
We apologize for the inconvenience.
Posted 5 months ago. Feb 02, 2017 - 19:40 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 5 months ago. Feb 02, 2017 - 19:35 EST
This incident affected: Smite PC - North America / Europe.