Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 9 months ago. Mar 13, 2018 - 09:47 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 9 months ago. Mar 13, 2018 - 09:31 EDT