Hirez Games possible issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 10 months ago. May 25, 2016 - 19:53 EDT
Update
Investigating: We are currently investigating this Hirez Games issue#smite #tribes #paladins
Posted 10 months ago. May 25, 2016 - 19:27 EDT
Investigating
Automated services have detected a possible problem our Atlanta servers and may affect all games. #SMITE #Tribes #Paladins. We are investigating.
Posted 10 months ago. May 25, 2016 - 19:21 EDT