Smite PS4 Matchmaking
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Jul 16, 2018 - 22:45 EDT
Monitoring
The issue with matchmaking on Smite PS4 has been addressed. We will continue to monitor.
Posted Jul 16, 2018 - 22:18 EDT
Investigating
There is currently an issue affecting matchmaking on Smite PS4. We are investigating the issue.
Posted Jul 16, 2018 - 21:57 EDT
This incident affected: SMITE (SMITE PS4).